Home Forums Sparkfun MP3 Shield Library Support Forum Issues with SparkFun MP3 Shield and Arduino UNO R3 Reply To: Issues with SparkFun MP3 Shield and Arduino UNO R3


I tried your suggestion of exercising the microSD card.  It seemed to work initially — after doing the following I was able to successfully use the MP3 Shield for the first time:

• Plugged the microSD card into a USB adapter and then into a PC.

• Copied all the files (.mp3, patches, etc.) to a folder on my computer’s desktop.

• Deleted the files from the microSD card, then reformatted the card (FAT32).

• After formatting, copied the files back onto the microSD card and ejected the card.

• Reinserted the microSD card into the MP3 Shield and everything worked — until I unplugged the Arduino UNO R3 / MP3 Shield and plugged it back in a few minutes later.  Then it was back to the same behavior as before.

I then tried the same process again (using a different WinXP machine), but it didn’t seem to help.  Still seeing:

Free RAM = 1070 Should be a base line of 1095, on ATmega328 when using INTx

Can’t access SD card. Do not reformat.

No card, wrong chip select pin, or SPI problem?

SD errorCode: 0X1,0X0

I tried reformatting the 2Gbyte microSD card as FAT(16) instead of FAT32, but that didn’t seem to help either.

There are no other shields involved — just the Arduino UNO R3 and the MP3 Shield, so there shouldn’t be any pin contention issues.  I’ll try commenting out the ErrorHalt and see if that helps clarify what is going on.

Any other suggestions appreciated — seems odd that it would work once and then stop.