Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #2955


    I am using an Arduino Uno, SeeedStudio Music Shield v1.0, and a 2Gb Micro SD card. My ultimate goal is to add on a RN-XV and its regulated power board (so I don’t blow the RN-XV with a 5v signal since it uses 3.3v) to make this all work wirelessly with my tablet.

    Right now I have your library somewhat working. I am getting error code 5 or 6 (they rotate around) when I plug in my Uno into USB and open up the serial monitor in the 1.0.5 IDE. It will allow me to play a few files and then it freezes. I have it presently set to 9600 baud in the sketch since that is the default speed of the RN-XN Wifi device.

    One think I need to check tonight is if I have it set to Seeeduno 1 from 0 in the config file, but am I missing any else to check to correct the two error codes?

    Would this error code cause the system to freeze after 10-20 secs?

    Also, is there any way I can ask for help in relation to the WiFi & RN-XV?

    Thanks in advance and also for the work on this library!



    Just some info to maybe help. Actually my SeeedStudios music shield board is a v1.2, not 1.0 like previously posted and I am using Arduino 1.0.5 on windows 7 Home premium 64Bit.

    All of the .053 patch files are in the root…. Still get error 5 or 6 on power on, and it still freezes.

    Opening up a command prompt and typing k: (to go to my MicroSD card) and then dir /x shows everything on except for the .bat & .pl files being shown in 8.3 format.

    VS_PLG~1.BAT   as opposed to   vs_plg_to_bin.bat
    VS_PLG~1.PL   as opposed to

    However it does not look like the FEMP3Shieldmainpage.h or the SFEMP3Shield.cpp files are calling for the Arduino to convert the the files, just for the arduino to reference the .053 files, so I assume that just having all of the .053 files in the root directory folder (k:/) along with the mp3 tracks (no sub folders) is all I need and that the .bat & .pl files can be deleted.

    I’ve also tried to use the provided mp3 files from the github page. They lock up the Arduino as soon as they are completed playing.



    Is there a reason that the first instruction line in the main sketch is shows the SPI in a orange color?  #include <SPI.h>

    Oddly enough deleting the the .bat & .pl lines made errors 5 & 6 stop…. 

    Here is my output upon opening up my serial monitor now…

    Free RAM = 2292 Should be a base line of 1040, on ATmega328 when using INTx
    Arduino SFEMP3Shield Library Example:
    courtesy of Bill Porter & Michael P. Flaga
    [1-9] to play a track
    [f] play track001.mp3 by filename example
    [F] same as [f] but with initial skip of 2 second
    [s] to stop playing
    [d] display directory of SdCard
    [+ or -] to change volume
    [> or <] to increment or decrement play speed by 1 factor
    [i] retrieve current audio information (partial list)
    [e] increment Spatial EarSpeaker, default is 0, wraps after 4
    [p] to pause.
    [r] resumes play from 2s from begin of file
    [R] Resets and initializes VS10xx chip.
    [t] to toggle sine wave test
    [m] perform memory test. reset is needed after to recover.
    [M] Toggle between Mono and Stereo Output.
    [g] Skip to a predetermined offset of ms in current track.
    [k] Skip a predetermined number of ms in current track.
    [O} turns OFF the VS10xx into low power reset.
    [o} turns ON the VS10xx out of low power reset.
    [D] to toggle SM_DIFF between inphase and differential output
    [S] Show State of Device.
    [V] Enable VU meter Test.
    [h] this help

    The problem is that the Arduino is still freezing up! The SD Card is a SanDisk 2GB, and it does not even have a class number on it, so I am going to assume that it is a class 1 or class 2.

    I started to mess around with the SFEMP3ShieldConfig.h file:
    Set line 074 to:   #define SEEEDUINO 1               (Checked that it was changed from 0 to 1 to for the seed board, which it was)
    Set line 088 to:   //#define GRAVITECH 0         (Commented the line since we are not using Gravitech)

    Also, as a note:
    TimerOne.h, and TimerOne.cpp are located in C:\Program Files (x86)\Arduino\libraries\TimerOne
    SimpleTimer.h, and SimpleTimer.cpp are located in C:\Program Files (x86)\Arduino\libraries\SimpleTimer

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.