Home Forums EasyTransfer Library Support Forum ET on the Intel Galileo Gen2

  • This topic has 2 replies, 2 voices, and was last updated 9 years ago by Bill.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #3268
    Anonymous
    Inactive

    Hi@all,

    First special thanks to Bill Porter, I really love your work. The ET Lib works since several month great for me.

    Now I tried to use it on my new Intel Galileo Gen2 Board and run into some issues.

    I tried to connect the Galileo Gen2 to Arduino Uno/Nano once as RX once as TXCommunication between Uno and Nano works, so sketch and cables are fine.

    When i try to compile EasyTransfer_RX_Example.ino on the Galileo I receive the following error message:

    In file included from EasyTransfer_TX_Example.pde:1:0:
    C:\ArduinoGalileo\arduino-1.5.3-Intel.1.0.4\libraries\EasyTransfer/EasyTransfer.h:42:20: fatal error: avr/io.h: No such file or directory
    compilation terminated.

    So the EasyTransfer Lib uses some AVR specific stuff and will not run on the x86 plattform.

     

    What I tried allready, without success:

    1.) remove line 42 from EasyTransfer.h (as mentioned in this forum for the Arduino Due)

    //#include <avr/io.h>
    With this little hack I can compile without issues but the serial communication will not work.

    2.) include the original io.h from the normal IDE to C:\ArduinoGalileo\arduino-1.5.3-Intel.1.0.4\hardware\arduino\x86\cores\arduino\avr

    The io.h has also several includes: coomon.h, fuse.h, lock.h, portpins.h,  sfr_defs.h, version.h
    When I copy them all to this folder I’m able to compile without any issues. But the Serial Communication will not work.

     

    Are there any other suggestions?

     

    King regards,
    Pac-Man

     

    #3272
    Anonymous
    Inactive

    Sorry for re-post, but I like to mention my versions:

    On my PC: Windows 7 x64
    IDE for Arduino DUE/UNO 1.5.8
    IDE for Intel Galileo: Arduino 1.5.3-Intel 1.0.4

    All are connected to the same power supply and grounded to each other
    Greetings
    Pac-Man

    #3282
    Bill
    Member

    Hmm,

    avr/io.h should not be needed, so you should be able to remove that without issues. It’s probably a relic from an old version.

    Why it won’t work on a Galileo I don’t know. The ET library uses the Stream class and should be portable with the Arduino IDE. Actually, maybe not. The Galileo may not be able to handle the malloc memory initialization. I’d have to get my hands on one or someone else try modding the library to not dynamically alloicate memory for the receive buffer.

     

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.