Home Forums PS2X PlayStation 2 Controller Library Support Forum No controller found error – tried everything

Viewing 1 post (of 1 total)
  • Author
  • #2989

    Hello everyone,


    I was hoping I could get some help over here. I already tried all the steps in the troubleshooting guide, and no progress…

    First things first: what I did so far. I am using:

    1. Dual Shock 2 original joypad from Sony

    2. Playstation to USB converter: http://www.vesalia.de/pic/usbps23adapter.jpg

    I disassembled the PSX part, and used it so I could easily wire it up to the breadboard

    3. Arduino uno

    There is also an image of what I did. The “A” and the “D” letters are only used so I wouldnt get lost with those pins, a is for ack pin and d is for data pin.


    So, Joypad is connected to the adapter, which then goes to breadboard. I only used the pins attention (arduino pin 10), command (11), data (12) and clock (13), as you can see in the image. I connected the +3,5V and GND to the arduino pins that supply that voltage.

    ACK and 7.5VDC pins are not connected (could this be the error? i have no idea what the ACK pin should do…)

    note: when i connect everything, i can light up the analog button LED diode.

    My baud rates are fine. Also, everything is connected nicely, i used the multimeter to check it out.

    I uploaded the example code to arduino, and on serial monitor i get the message “no controller found, check the wiring bla bla bla”.

    I have no idea what else to try. I tried all options on both voltage levels (3.3V and 5V). Pull-up resistor (10k), changing the CLK in .h file, removing the check in example….


    So, basically, does anyone have any ideas where I am wrong?

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.