Home Forums EasyTransfer Library Support Forum "no matching function for call to begin()" trying to compile the samples

  • This topic has 7 replies, 2 voices, and was last updated 10 years ago by Anonymous.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3108
    Anonymous
    Inactive

    I’m running Arduino 1.0.5 R2, and am trying to run the sample code from your library (thanks for that!), however whenever I try to compile the sample code I get the following errors:

    EasyTransfer_2Way_wPot_Example.pde: In function ‘void setup()’:
    EasyTransfer_2Way_wPot_Example:45: error: no matching function for call to ‘EasyTransfer::begin(byte*, unsigned int, usb_serial_class*)’

    I’ve verified that the library is in the correct location (C:\Program Files\Arduino\libraries\EasyTransfer), and restarted the Arduino IDE. Actually I’m selecting the samples from the IDE, so that should be loaded in fine.

    Could you shed any light on what might be the problem?

     

    #3109
    Anonymous
    Inactive

    An update, the samples compile and run on my Arduino Uno.   It seems to be that my Teensyduino 2.0 is the problem, I still get this error:

    Arduino: 1.0.5-r2 (Windows NT (unknown)), Board: “Teensy 2.0″TinySender.ino: In function ‘void setup()’:TinySender:26: error: no matching function for call to ‘EasyTransfer::begin(byte*, unsigned int, usb_serial_class*)’C:\Program Files\Arduino\libraries\EasyTransfer/EasyTransfer.h:46: note: candidates are: void EasyTransfer::begin(uint8_t*, uint8_t, HardwareSerial*)

    For more information on the teensy:

    http://www.pjrc.com/teensy/teensyduino.html

    Non-Serial USB (no driver install message on Windows)

    Download the arduino setup:

    http://www.pjrc.com/teensy/td_download.html

     

    Am I out of luck using your library with this board?  I’ve got a pair that would be quite nice to use in a current project.

    #3110

    the three directories in the package need to be :

    .\Arduino\libraries\EasyTransfer

    .\Arduino\libraries\EasyTransferI2C

    .\Arduino\libraries\EasyTransferVirtualWire

    The git package may put them incorrectly into

    .\Arduino\libraries\EasyTransfer\EasyTransfer

    .\Arduino\libraries\EasyTransfer\EasyTransferI2C

    .\Arduino\libraries\EasyTransfer\EasyTransferVirtualWire

    Hence your error that it can not find it.

    Additionally it will only work on an UNO. Leo’s USB will have issues.

    #3111
    Anonymous
    Inactive

    Thanks Michael for the response, I’ve made sure that all 3 directories are where they should be.

    I’m not sure what you mean by Leo’s though.  Is the Teensy a Leo?

    #3112

    try

    https://github.com/mpflaga/Arduino-EasyTransfer.git

    I have updated this fork to support the 32U4. Note the Leonardo and Teensy both use the 32U4.

    This fork compiles on both UNO and Leonardo. Should compile on the Teensy.

    #3114
    Anonymous
    Inactive

    Thank you Michael for continuing to try to get this working.  I’ve downloaded and installed your fork.  Indeed it compiles on the Leonardo profile.  However, I still have troubles compiling it for my Teensy.  It’s different now though:

    In file included from EasyTransfer_RX_Example.pde:1:
    C:\Program Files\Arduino\libraries\EasyTransfer/EasyTransfer.h:50: error: ‘Serial_’ has not been declared
    C:\Program Files\Arduino\libraries\EasyTransfer/EasyTransfer.h:62: error: ISO C++ forbids declaration of ‘Serial_’ with no type
    C:\Program Files\Arduino\libraries\EasyTransfer/EasyTransfer.h:62: error: expected ‘;’ before ‘*’ token
    EasyTransfer_RX_Example.pde: In function ‘void setup()’:
    EasyTransfer_RX_Example:19: error: no matching function for call to ‘EasyTransfer::begin(byte*, unsigned int, usb_serial_class*)’
    C:\Program Files\Arduino\libraries\EasyTransfer/EasyTransfer.h:50: note: candidates are: void EasyTransfer::begin(uint8_t*, uint8_t, int*)

    I thought I’d try a couple things.  I verified that my hardware profile for the teensy indicates an mcu of “atmega32u4”, it did.  I also took out the ifndef’s so that it only selected the __atmega32u4__ calls, still no dice.

    Does the error message mean that the sample sketch is not passing in the Serial reference to the easytransfer.h?

    #3115

    I have updated the fork to support the Teensy Core. It uses a different core library as it came out before the Leonardo. The Teensy’s core uses a class usb_serial_class while the Leo uses Serial_ and the none USB devices use a class of HardwareSerial. Hence the library needs to build the corresponding Class to bind to.

    I have tested that it compiles on IDE 1.0.5 with Teensy patch applied.

    #3116
    Anonymous
    Inactive

    That did it!  Thank you!  I really appreciate the support!  I don’t know if it goes to you, but I donated a few bucks!  Cheers!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.