Home Forums PS2X PlayStation 2 Controller Library Support Forum Reading buttons, but not the right buttons

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #3208

    I’m using a Dualshock Silver PS2 Controller with an Arduino Uno. After a lot of tinkering, I bypassed the error and controller type because I kept getting unknown controller. Even after that I still had to move which pins everything was on, with data on 4, cmd on 6, att on 8, and clock on 9, and also made the code match it in the Arduino sketch. I am running the controller on 5V, and have tried pulling down data, but I still get these weird results when these buttons are pressed:

    *Select is always read as held down, as well occasionally L3*

    Select = L3 + R3

    Start = Start + L2 + R2

    Left D Pad = Left D Pad + L2 + R2 (All D pads say being pressed down at 0 hardness)

    Down D Pad = Left + Down D Pad

    Right D Pad = Right + Down D Pad

    Up D Pad = Up + Right D Pad

    Square = Square + L3

    Cross = Cross + L3

    Triangle = Triangle + Circle + L3

    Circle = Circle + Cross + L3

    L3 = L3 + R3 + Start

    R3 = R3 + L3 + Start

    L1 = Stick Values + Triangle + L3

    R1= Stick Values + Circle + Triangle + L3 (On both of these stick values looked off, but DID change values when the sticks moved)

    L2 = Nothing

    R2 = Nothing

    I am almost 100% sure I have the pins of the controller labeled right because I’m going by pin number, not wire color. I actually have the wires soldered directly on the pins. Any help would be great!


    EDIT: Interestingly, changing the clock speed to 15 fixed the problem


    ********Still Not Reading Analog though**********


    Actually has pressure, didn’t uncomment… oops

    Although can’t get the rumble even after uncommenting, going to play around with that

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.