Home Forums Sparkfun MP3 Shield Library Support Forum vs1053 on arduino leonardo and nano ?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #3186

    hi guys !

    i’m attempting to make functionnal a geeetech vs1053 board with a leonardo (for testing) and finally with a nano (with soldering)

    for the moment, on my leonardo, i have added the SFEMP3Shield library and the last SdFat.

    compilation and upload looks right.

    but when i tap “1” in serial window, it return “Error code: 2 when trying to play track”

    dreq, xdcs, xreset, xcs, cs are plugged on good pins like wrote in SFEMP3Shield.h

    i have tried to plug miso,mosi, sck like a uno without result.

    i have also tried to plug them on ICSP connector without result

    not connect the SPI cause the same message.

    conclusion, i think it’s a problem with SPI connection. but i don’t know how connect it…

    someone can help me ( in a simple english langage if it’s possible :D, i think you have seen that i don’t speak english very well…)

    thanks a lot for help !


    no, i haven’t seen this link.

    when i try to understand de specificty of leonardo, i found that:



    Support for Arduino Leonardo is afflicted by having the SPI pins not routing the same pins as the UNO. This is similar to the Arduino Mega. Where as it appears it should simply work with additional jumpers, from the Leonardo’s ICSP port, which has the SPI pins to the MP3 shields equivalent SPI pins. `
    Leo’s ICSP4 to the MP3’s D11 for MOSI
    Leo’s ICSP1 to the MP3’s D12 for MISO
    Leo’s ICSP3 to the MP3’s D13 for SCK `
    and remember to NOT use D10 as an input. It must be left as output.



    i have allready made that by myself without result.

    i think i’ll test with my nano to see if the problem is the same.



    same problem with arduino nano:

    “Error code: 2 when trying to play track”

    and with him, output numbers are same as arduino uno… i don’t understand why that doesn’t work…


    i haven’t seen before, i have another error code before this one.

    it appears when the card boot up:

    “Error code: 1 when trying to start MP3 player”

    1 *Failure of SdFat to initialize physical contact with the SdCard

    i have made tests with two cards, a brand new micro sdhc 4go with sd adapter and an old 256mo sd card…

    i’ll test another one…


    same problem with another 512 mo sd card and 16gb micro sdhc …

    another solution ?



    i have tested to use SdFat exemple, like SdInfo…

    he return:

    “card.init failed
    SD errorCode: 0X1
    SD errorData: 0X0”

    if i understand right, there is two way of my problem:

    1- i’m dumb and there is a connection problem and SPI doesn’t work properly (maybe true)

    2-my geeetech pcb is dead (i hope no…)


    that’s right ?


    I read two symptoms.

    1) that when you play a file you get a #2.

    2) the later the SDcard won’t initialize.

    The first symptom would indicate that you may have gotten past the SDcard initialize, when running the demo. Assuming your were attempting to run *MP3Shield_Library_Demo.ino

    Note that the native SdFat examples are not aware of the VS1053. Hence the native SdFat examples do not disable the VS1053’s chipselects. Rather they leave them floating. Which can cause the native examples from properly initializing, if the VS1053 floating chipselects float in the wrong way. I always tweak the SdFat examples so that D8 (VS1053-Reset) is LOW, so that the VS1053 won’t interfere with testing the SdCard.

    It is also worth testing different SdCards of different make and model.

    If #1 is true and the demo did initialize the SdCard and you got a #2 error while attempting to play a file. It is likely not named properly. I originally used the SdCard Example that would dump the directory. However, you can try to use the FilePlayer.ino it will list the directory and allow you enter an index of the file you want to play.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.